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The updates presented in this brochure were made from January 2023 until  January 2024. We have fixed numerous bugs and implemented 683 new features. Only a

small selection of new features is presented in this document.

From January 2023 till January 2024, Arahne software covered the following versions:

• ArahWeave: from version 9.7s till 10.0

• ArahPaint6: version 6.0.3140 till 6.0.3541

• ArahDrape: from version 3.3n till 3.3r

https://www.arahne.si/
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1. ARAHWEAVE

1.1 THREAD GROUPING WEAVES

WHAT DOES IT DO?

ArahWeave can now simulate thread grouping weaves in which all threads follow an equal path through the weave. As equal threads move closer together,

panama weaves can have larger gaps.

WHERE AND HOW TO USE IT?

Go to Fabric > Simulation, Density tab and adjust the Displacement for Warp and Weft.

https://www.arahne.si/
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1.2 SUPPORT FOR READING AND WRITING ELTEX .EJP

WHAT DOES IT DO?

ArahWeave and ArahPaint can now read Eltex .EJP format of jacquard selvedges. ArahWeave can also write it.

WHERE?

Go to Fabric > Save cards for 
production, under Format choose 
Eltex or load the .EJP file from 
Weave > Browse cards.

https://www.arahne.si/
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1.3 LOOM LAYOUT INFO IN THE TOOL-TIP OF IMAGE BROWSER

WHAT DOES IT DO?

In ArahWeave and ArahPaint's image browser, we added extra information about loom layout to the tooltip. For example, the number of weft bytes used for

loom weft control in a Bonas file, or information about zones that define the meaning of various parts of the jacquard card in Stäubli JC5 format, etc.

WHERE AND HOW TO USE IT?

Go to Browser, in ArahWeave from Weave > 

Browse cards and in ArahPaint go to regular 

Image browser.  When you hover the mouse 

over the image icon, information will appear 

in the tool-tip.

https://www.arahne.si/
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1.4 COLORING MODES OF WEAVES IN DECOMPOSED

WHAT DOES IT DO?

We added additional 3 weave views that take the colors from yarn colors.

WHERE AND HOW TO USE IT?

In Weave Editor window go to View and select among different weave views. 

https://www.arahne.si/
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You’re already familiar with the 4 Views in Decomposed:  Decomposed colors, Decomposed colors warp, Decomposed colors weft, Decomposed colors

selected. 

DECOMPOSED COLORS VIEW DECOMPOSED COLORS WARP

DECOMPOSED COLORS WEFT DECOMPOSED COLORS SELECTED

https://www.arahne.si/
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You can now choose among the 3 new views: Yarn colors weave, Yarn colors warp and Yarn colors weft.

                                                                 YARN COLORS WEAVE                                                                                           YARN COLORS WARP

YARN COLORS WEFT

https://www.arahne.si/
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1.5 WEAVE CURSOR

WHAT DOES IT DO?

The weave cursor indicates which point will be changed even before you click the mouse. Some users are unfamiliar with mouse hot point: when you click,

the computer takes the value from the mouse pointer's sharp tip rather than the center. The two cursors are coordinated; they indicate where the point

from the decomposed weave editor will land on the main weave. This makes it easier to draw the precise stitch points. Additionally , when pointing the

mouse pointer on the fabric simulation, the weave cursor also displays the position on the weave in the editor.

SAME WEAVE POINT

https://www.arahne.si/
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1.6 SUPPORT FOR SPECTROPHOTOMETER NIX SPECTRO 2

WHAT DOES IT DO?

ArahWeave now enables direct color measurements using the Nix Spectro 2, a compact portable spectrophotometer. In addition to CIE Lab values in D65

and 2° or 10° observation angles, you will receive full reflectance data. You can also change the measurement mode to M2 to prevent the effect of optical

brighteners. Best of all, it's relatively affordable: https://www.nixsensor.com/nix-spectro-2/

WHERE AND HOW TO USE IT?

Connect your Nix Spectro 2 to a 
computer. Under Colors, go to 
Change > Measure colors and select 
Nix Spectro 2. After calibration you 
can begin to measure your colors.

Note: On Linux, you need to add a 
user to "aux" group to gain 
permissions to interface the program 
with USB connection to Nix. On SUSE 
Linux, you can do it in the YAST 
system administration tool, under 
Security and Users > User and Group 
management, Edit > Details.

https://www.nixsensor.com/nix-spectro-2/
https://www.arahne.si/
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1.7 ADD REGULATOR

WHAT DOES IT DO?

Customers have suggested an alternative way of hiding the defect at the start or end of regulator pattern: add another regulator point. This was always

achievable simply by drawing it with the mouse. Customers, however, desired an automatic function, because they frequently work on very large designs

that require numerous mouse clicks.

WHERE AND HOW TO USE IT?

In Weave Editor window go to Tools > Add regulator to, and select Top, Bottom or Ground.

https://www.arahne.si/
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1.8 BONAS HARNESS XML SUPPORTED

WHAT DOES IT DO?

ArahWeave can read Bonas harness XML files as black and white graphics, with unused hooks colored black. Users  who want to modify existing Bonas

harness files can thus add another level of skipped hooks and re-save the Bonas harness XML. Reading is currently supported in version 1.1 and 2.0 formats,

but writing is only supported in version 1.1.

WHERE AND HOW TO USE IT? 

To open it go to Weave > Browse cards. To re-save it, go to Fabric > Save cards for production, under Format select Bonas Harness .XML.

                

https://www.arahne.si/
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1.9 QUADRUPLE WEAVES

WHAT DOES IT DO?

In the ArahWeave Weave Editor window use the quadruple function to easily create of quadruple weaves with clockwise or anticlockwise rotation. This is

one of the classical approaches for creating complex weaves.

WHERE AND HOW TO USE IT?

To use it draw a simple square weave in the Weave Editor window, then go to Edit > Quadruple, and choose either clockwise or anticlockwise direction to

create a new weave.

 
STEP 1: Draw a simple weave STEP 2: Select the quadruple 

function to create a complex 
weave

STEP 3: Apply the new weave 
to fabric simulation

https://www.arahne.si/
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1.10 OPTIMIZATION FOR VERY LARGE WEAVES

WHAT DOES IT DO?

One of the advantages of ArahWeave is that it handles well large weaves. If you need a complicated ground weave in extra weft or fil coupe fabric,  you can

enter complete jacquard weaves in jacquard conversion. In some extreme cases, such as the one shown on the picture (ground component weave of

10800x4200), even ArahWeave got slow when resizing the window and applying the weave. We have now optimized the program, so that it works quickly

even on such edge cases.

Fabric design by Lanificio di Sordevolo

https://www.arahne.si/
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1.11 SAVING OF JACQUARD SINGLE FILES FOR STÄUBLI, BONAS AND GROSSE, ON MORE THAN 10 FLOPPIES

WHAT DOES IT DO?

Numerous jacquard manufacturers support multi-floppy jacquard formats (Stäubli JC3, JC4, JC5, Bonas, Grosse), while ArahWeave supported splitting and

saving of a single card file across multiple floppies. However, a single card file could only be split into 10 floppies.

Some of our customers create huge designs that require the weave divided to more than 10 floppies. In order to facilitate the saving of a single design on

more than 10 floppies, we made improvements to the ArahWeave program and thus our customers don’t need to spend 100.000 EUR on a new jacquard

loom to weave their large designs.

Very large weave, 5120x48820

https://www.arahne.si/


 www.arahne.si Arahne updates 
Jan 23 – Jan 24

17  

WHERE AND HOW TO USE IT?

In Save cards for production window, select the saving destination Emulator and write to floppy to save the whole design split among several floppies.

https://www.arahne.si/
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1.12 NEW COLLECTION OF WRINKLES

WHAT DOES IT DO?

We have collected over 90 different wrinkle images for  you to utilize in your fabric  simulations.  If  you want to add a finishing touch to your fabric

simulation, such as hair, drapes, seersucker, fur, denim, bumps, and so on, use wrinkle image.

WHERE AND HOW TO USE IT? 

Go to Fabric > Simulation, then click on the Wrinkle tab and load the image with the desired wrinkle effect. To get varied results, change the size with Zoom

and the intensity with Strength. Unwrinkable yarns, Unwrinkable density, Offset, and X&Y displacement are other options.

Fabric design by Lyontex

https://www.arahne.si/
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1.13 ROTATE DESIGN IN REPEAT

WHAT DOES IT DO?

In ArahWeave you can now rotate an image at an angle in seamless repeat. Our colleague Anton did his homework and calculated all of the possible angles

that would keep the image in seamless repeat. Only at certain angles will the image repeat, and even then only for square images. Images that are not

square can only be rotated in one direction at a time: horizontally or vertically.

WHERE AND HOW TO USE IT?

In Jacquard conversion window go to File > Rotation 
in repeat. You can select from 99 different angles that 
have been calculated to produce an image in a 
seamless repeat. You can rotate the image clockwise 
or counterclockwise. For non-square images you can 
choose to keep the repeat either horizontally or 
vertically. 

CLOCKWISE 
ROTATION 

COUNTERCLOCKWISE 
ROTATION 

IMAGE SIZE

ROTATION
ANGLE

NUMBER 
OF 

REPEATS

HORIZONTAL 
DIRECTION

VERTICAL 
DIRECTION

https://www.arahne.si/
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ROTATION OF A SQUARE IMAGE, SEAMLESS REPEAT 
IN ALL DIRECTIONS

ROTATION OF A NON-SQUARE IMAGE, SEAMLESS REPEAT 
ONLY IN ONE WAY, HORIZONTAL OR VERTICAL

https://www.arahne.si/
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1.14 BLANKET LABEL

WHAT DOES IT DO?

You can create and weave a blanket from jacquard fabric with each section labeled separately.

WHERE AND HOW TO USE IT?

In Thread pattern insert the number of threads for warp and weft sections. In Jacquard conversion window select Blanket label. In the first two colors,

insert the weaves for the label, and in the third color insert the total weave of the fabric. Insert the number of sections for warp and weft, offset, title

height, position. Then click OK and check the labels on the simulation.

NUMBER OF THREADS FOR WARP AND 
WEFT SECTIONS

SELECT BLANKET LABEL

1ST AND THE 2ND WEAVE FOR LABELS, 
THE 3RD COPY/PASTE THE WHOLE 

FABRIC WEAVE

NUMBER OF WARP AND 
WEFT SECTIONS, TITLE 

HEIGHT

https://www.arahne.si/
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2. ARAHPAINT                                                                                                 

2.1 SHADING ALGORITHMS

WHAT DOES IT DO?

In addition to Random and Isoline, ArahPaint now supports three new shading algorithms: ordered dithering, error diffusion, and weave.  They work with all

drawing tools (including fill and text), with multicolor, in all directions and in repeat. 

https://www.arahne.si/
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WHERE?       HOW TO US IT?

Below the brush size, the second square next to gradient effect. Select any drawing tool, fill or text. Select one of the gradient effects, two-

colored or multicolored and the shape. Next choose among the 5 shading 

algorithms. 2 of them were already developed last year (random and isoline). 

Now you can choose also among Weave, Ordered dithering and Error 

diffusion.

USE FG/BG COLORS 

OR ALL THE COLORS 

IN THE PALETTE 

BETWEEN FG AND 

BG COLORS

SELECT SHAPE

SELECT 

SHADING 

ALGORITHM

SELECT 

GRADIENT 

EFFECT

https://www.arahne.si/
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WEAVE SHADING ORDERED DITHERING&ERROR DIFFUSION SHADING

ORDERED DITHERING

ERROR DIFFUSION

Select either ordered dithering icon or error diffusion icon to draw in the 

selected shading algorithm. Error diffusion is scattering of dots which make the 

most visually smooth transition between two colors.

To use weave shading, load a weave under Brush tab and start 

drawing. 

Weave shading algorithm  uses the weave in Brush  to create a 

weave shading effect.

https://www.arahne.si/
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2.2  READING PHOTOSHOP .PSD AND .PSB IMAGE FORMAT

We have added reading of Photoshop .PSD and .PSB image format to ArahPaint and ArahWeave. We rely on external tools to read it, so it only works on

Linux and Mac, not on Windows, which lacks those tools. Some more exotic variants like duo-tone or multi-channel are not supported. Multi-layer images

are collapsed into a single layer. If you need to keep the layers for editing purposes, we suggest you use the GIMP.

What is the difference between .PSD and .PSB files? PSB files support even larger images, instead of maximum of 30.000 pixels, PSB supports 300.000 pixels.

And maximum file size can be bigger than 2 gigabyte.

           

https://www.arahne.si/
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2.3 TRUCHET TILES

We digitalized a collection of 84 Truchet tiles, so you can use them to create interesting random patterns in only a few clicks using the Random function in

ArahPaint. We use the base tiles designed by Edward Borlenghi http://arearugscarpet.blogspot.com/2014/04/the-curse-of-truchets-tiles.html

TRUCHET TILE 35 TRUCHET TILE 45 TRUCHET TILE 49

https://www.arahne.si/
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WHERE AND HOW TO USE IT?

In ArahPaint load the Truchet tile (under data/img) from the Browser. Go to Image > Drawing in repeat. Select Preview and enter the number of repeats in

horizontal and vertical directions. Then click on Random to generate a pattern. Click on Random a few time until you get the desired pattern, then select

New picture and click OK. 

2. INSERT 
THE NUMBER 
OF REPEATS

1. SELECT 
PREVIEW

3. CLICK ON 
RANDOM TO 

CREATE A 
PATTERN

https://www.arahne.si/
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2.4 IKAT

WHAT DOES IT DO?

Previously, the Ikat filter in ArahPaint6 would only move one thread by a random size of the Value parameter. You may now set the x and y parameters, and

it will move multiple groups of threads. 

WHERE AND HOW TO USE IT?

Click on the Measure tool and enter the following parameters: X, Y, Value. Go to Filters > Ikat and select the direction: Horizontal, Vertical, or both.

https://www.arahne.si/
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2.5 FIXED CUT AND PASTE

We fixed the cut and paste in ArahPaint6, so now the pasted selection no longer changes the position on the image. Click on the social media icon , to

watch the tutorial on Facebook, Instagram or Linkedin.

https://www.arahne.si/
https://fb.watch/q0rxGVxp4H/
https://www.instagram.com/p/C2AVnmlsk8s/
https://www.linkedin.com/feed/update/urn:li:activity:7151584278714212352?utm_source=share&utm_medium=member_desktop
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2.6 TRANSLATION TO PERSIAN (FARSI)

We have translated ArahPaint6 to Persian language. To change the language, go to Help > Save setup and select Farsi.

https://www.arahne.si/
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3. NEW SHORT TUTORIALS

Click on the social media icon, to watch the tutorial on Facebook, Instagram or Linkedin.

Truchet tiles

https://www.arahne.si/
https://www.instagram.com/reel/CoXY8hGNzCl/?utm_source=ig_web_copy_link&igsh=MzRlODBiNWFlZA==
https://www.linkedin.com/feed/update/urn:li:activity:7028726032975183872?updateEntityUrn=urn%3Ali%3Afs_feedUpdate%3A%28V2%2Curn%3Ali%3Aactivity%3A7028726032975183872%29
https://fb.watch/psZXRFPuaP/
https://www.instagram.com/reel/CqS9yp1rqyh/?utm_source=ig_web_copy_link&igsh=MzRlODBiNWFlZA==
https://www.linkedin.com/feed/update/urn:li:activity:7046128928725315585?utm_source=share&utm_medium=member_desktop
https://fb.watch/ps-umWN2UF/
https://www.instagram.com/reel/CwCujmTMMgM/?utm_source=ig_web_copy_link&igsh=MzRlODBiNWFlZA==
https://www.linkedin.com/feed/update/urn:li:activity:7097887462366097409?utm_source=share&utm_medium=member_desktop
https://fb.watch/pt0DLYTdxU/
https://www.instagram.com/p/CuhBHzrRx_x/
https://www.linkedin.com/feed/update/urn:li:activity:7084134726600396802?utm_source=share&utm_medium=member_desktop
https://fb.watch/pt0fUgxjCn/
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https://fb.watch/pt0TTMZq3R/
https://www.instagram.com/reel/CyLIJVcMrJ4/?utm_source=ig_web_copy_link&igsh=MzRlODBiNWFlZA==
https://www.linkedin.com/feed/update/urn:li:activity:7117090531880370176?utm_source=share&utm_medium=member_desktop
https://fb.watch/pt4usoCeAH/
https://www.instagram.com/reel/Cyk2-O-sp12/?utm_source=ig_web_copy_link&igsh=MzRlODBiNWFlZA==
https://www.linkedin.com/feed/update/urn:li:activity:7120705090922983425
https://fb.watch/pt4XTR2SCY/
https://www.instagram.com/reel/C0CMWyKsB75/?utm_source=ig_web_copy_link&igsh=MzRlODBiNWFlZA==
https://www.linkedin.com/feed/update/urn:li:activity:7133841521782456321
https://fb.watch/pt4IVbH73H/
https://www.instagram.com/reel/CyvoQ82MDtz/?utm_source=ig_web_copy_link&igsh=MzRlODBiNWFlZA==
https://www.linkedin.com/feed/update/urn:li:activity:7122518840529367040
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